View unanswered posts | View active topics It is currently Wed Nov 22, 2017 11:34 am



Reply to topic  [ 1 post ] 
 Hot-Linking - .htaccess not working 
Author Message
Junior Member

Joined: Thu Dec 20, 2007 12:40 pm
Posts: 1
Post Hot-Linking - .htaccess not working
I have read about a hundred pages on hotlinking today and I have been trying to implement an .htaccess file to prevent it, but so far nothing is working.

What I want to do is stop people from directly downloading from my DL directory.

i.e. www.mysite.com/download/myfile.avi

If they type in the above I want an error page displayed.

Currently I have an .htaccess file in the root directory of my site, as follows.


RewriteEngine on
RewriteOptions inherit

RewriteCond %{HTTP_REFERER}!^$
RewriteCond %{HTTP_REFERER} !^http://www.mysite.ca/.*$ [NC]
RewriteRule .*.(avi|AVI|mpg|MPG|wmv|WMV|swf|SWF)$ - [F]

This is very simplistic, but I just want to get it working, then I can add other options or whatever.

Any help on what I am doing wrong is appreciated.


Thu Dec 20, 2007 12:42 pm
Report this post
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
© Copyright 2003-2008 www.php-editors.com. The ultimate PHP Editor and PHP IDE site.